BTHS National Honor Society - Issues on Safari – Incident details

All systems operational

Issues on Safari

Resolved
Degraded performance
Started over 3 years agoLasted 2 days

Affected

Website

Degraded performance from 3:56 PM to 12:03 PM

Updates
  • Resolved
    Resolved

    This incident has been marked as resolved as the cause of the issue was Safari's obsolete implementation of a certain technology. There is currently no fix for this.

  • Identified
    Identified

    We are continuing to work on a fix for this incident.